生活の跡

個人的な備忘録

yarnのプラグインのバージョンを確認する

経緯

Gatsbyでエラーが解消できず、ひとまず怪しそうなプラグインのバージョンを調べたかったのであります。

環境

  • macOS Big Sur(11.2.3)
  • yarn 1.22.10

確認方法

ターミナルで以下のコマンドを実行します。

$ yarn info [プラグイン名] versions

私が調べたかったプラグイン gatsby-source-contentful の場合は、次のようにすればOKです。

$ yarn info gatsby-source-contentful versions

参考

yarn のドキュメント(yarn info のページ)を参考にしました。

おわりに

単純なコマンドですが、「yarn プラグイン バージョン確認」でググっても日本語の参考ページが見つかりませんでした。yarnのコマンドまとめ的なページはエンカウント率が高いのですが、ピンポイントな情報が見つけづらいと感じる今日この頃です。

慣れている人からすれば「ドキュメントに書いてあるだろ」ということだと思いますが、初学者にとっては英語のドキュメントで該当ページを探すのも一苦労なんですよね。慣れていくしかないのでしょうが。。